browse the Mesh network with your home network MikroTik router

Home Forums Network Integration browse the Mesh network with your home network MikroTik router

This topic contains 0 replies, has 1 voice, and was last updated by  KD7VEA 7 months, 1 week ago.

Viewing 1 post (of 1 total)
  • Author
    Posts
  • #384

    KD7VEA
    Keymaster

    I decided to move my home network over to a Mikrotik router. for those who may not know, MikroTik routers are affordable, versatile routers with tons of features which makes them great for those of us who really get into the networking side of things. I run a few Mesh services from home, the web server running this site, and a few other devices. the MikroTik router does a great job of handling all of the jobs I throw at it. The issue with this is trying to redirect all of my mesh traffic out to my node so that I can go from browsing the internet to drilling through the Mesh network with no extra steps. Mikrotik routers don’t support this function, but there are a few tricks that can be done to get this working, so if you are running a MikroTik router and want to be connected to both your home network and the mesh network at the same time, here are the steps it takes.

    here are some specs of my system
    ethernet 1 is my WAN connection to my modem
    ethernet 2 is my lan connection to my main switch where everything else is connected.
    my home network DHCP server is set to 192.168.1.X with a subnet of 255.255.255.0
    My Mesh node is set to NAT with an IP of 192.168.1.200

    Start by going to the terminal here are the commands
    /ip firewall layer7-protocol (press enter)

    add name=”dns for local.mesh” regexp=”\\x05local\\x04mesh.\\x01″ (press enter)

    .. (yes, type 2 periods and then enter to exit out of the Layer 7-protocol section)

    /ip firewall nat (press enter)

    add action=dst-nat chain=dstnat protocol=udp dst-port=53 in-interface=(enter your LAN interface port here) layer7-protocol=”dns for local.mesh” to-addresses= (press enter)

    add action=masguerade chain=srcnat protocol=Udp
    dst-port=8080 in-interface=(enter your LAN interface here) to-ports=8080

    /ip route (press enter)

    add dst-address=10.0.0.0/8 gateway= (press enter)

    The last step is to now exit the Terminal and go to Webfig(Its easier in webfig or WinBox)
    go to IP>DNS

    I can now browse to anything on my home network, the internet, and the mesh network seamlessly.

    • This topic was modified 7 months, 1 week ago by  KD7VEA.
    • This topic was modified 7 months, 1 week ago by  KD7VEA.
    • This topic was modified 7 months, 1 week ago by  KD7VEA.
    • This topic was modified 7 months, 1 week ago by  KD7VEA.
    • This topic was modified 7 months, 1 week ago by  KD7VEA.
    • This topic was modified 7 months ago by  KD7VEA.
Viewing 1 post (of 1 total)

You must be logged in to reply to this topic.